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What’s New in JoinNet Editor 1.11.0 
 

Play ALL Audio  If there are multiple audio/video streams, normally one can 

only select a user name and click OK to start playback the 

user’s audio.  

 

Now, if you want to hear ALL audio during the playback, 

just hold down CTRL. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Set to Blank Page  You can right-click a slide and select Set to Blank Page to 

“remove” the slide. 
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Preface 
 

JoinNet Editor (Jeditor) lets you edit a .jnr file (JoinNet Recording file or JNR file) that 

was created by a HomeMeeting MCU server at the end of an online meeting conducted 

by JoinNet users. A Jeditor user needs to download his JNR files from the HomeMeeting 

MCU servers first, and then open the JNR files with Jeditor to begin editing.  

 

A HomeMeeting user can use JoinNet as a local player to open a JNR file; moreover, he 

can upload a JNR file to a HomeMeeting MCU server and then use the JoinNet 

Messenger to share the JNR file for online JoinNet playback. Please refer to the 

Messenger User Guide for detailed discussion on JNR file sharing.  

 

Using Jeditor, you can 

 

� Preview and cut recorded data in a JNR file, including audio, video, text chat, and 

application data such as shared desktop and remote control. 

� Browse through all slides presented in a JNR file and rename each slide. 

� Reset the default videos to be displayed in the Meeting Room window of JoinNet. 

� Add bookmarks to a JNR recording file, so that JoinNet viewers can quickly 

navigate to the cue point defined by a bookmark during a JNR file playback. 

� Set a password to a JNR file, so that JoinNet viewers need to type the password in 

the JNR Password field to play back the JNR file. 

� Lock a JNR file to disable file editing permanently. 

� Edit the properties of a JNR file for better archiving and retrieving. 

 

System Requirements 
 

The following are the recommended system requirements for running Jeditor. 

 

� 333 megahertz or higher processor clock speed 

� Windows XP / 2000 / 2003 

� 100 MB of available hard disk space 

� 64 MB of RAM or higher 

� Sound card 

� 16 bit color at 1024x768 or higher resolution 

 

 



HomeMeeting Document: JoinNet Editor (Jeditor) User Guide   3

Jeditor Workspace 
 

 Jeditor contains multiple palettes as a workspace for editing 

a JNR file. You can move and resize each palette according 

to your personal preference or auto-arrange all palettes to 

their default positions. Jeditor will save the entire layout 

accordingly. The following figure shows the Jeditor 

workspace and all its palettes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Timeline Palette Graphically represents the location, duration, or signal 

amplitude for the actions of all data types recorded in a 

JNR file, including Audio, Videos, Application Data (i.e., 

data from Shared Desktop and Remote Control), Text, 

Slide, Web Page, and Attendee. The time scale, represented 

by a pixel, is in 10seconds, second, 100ms, 10ms and ms. 

 

Information Palette Shows detailed information of a data type at a selected 

location or in a selected segment of the data type. 

 

Attendee Palette Shows every attendee’s check-in and checkout time. 
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Slide Palette Shows the exact time and the title of every uploaded slide 

or file. 

 

Text Chat Palette Displays the exact time and the user name of every text 

chat input. 

 

URL Palette Displays the exact time and the Uniform Resource Locator 

(URL) of every joint web browsing. 

 

Bookmark Palette Shows the cue point and the title of every bookmark added. 

During a JNR playback, viewers can quickly navigate to a 

cue point by double-clicking a bookmark displayed by 

JoinNet. 

 

Default Video Palette Shows the cue point and the user name of every default 

video added. During a JNR playback, default video is the 

prime video to be displayed by JoinNet starting at the cue 

point reset by Jeditor. 

 

CutBlock Palette Shows the segment(s) and type(s) of data to be cut from a 

JNR file.  

 

Timeline Panels  There are three timeline panels: (1) Current Location Panel 

shows the current location of a mouse cursor on the 

Timeline Palette, (2) Duration Panel shows the Start Time 

and End Time of a JNR file, and (3) Segment Panel shows 

the Start Time and End Time of a selected segment. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Duration Panel Current Location Panel  Segment Panel 
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Current Location Denotes the timeline location of mouse cursor on a data 

type or on the timeline. You can specify the movement of 

mouse cursor on the Timeline Palette in different time unit: 

 

1. On the toolbar, select View > Unit. 

2. In the drop-down list, select the desired unit: 

Millisecond, 10 Millisecond, 100 Millisecond, Second, 

10 Second, or Fit to Window. 

 

Note that the timeline is rescaled in corresponding to the 

choice of time unit. You can move the mouse cursor on the 

Timeline Palette after setting the new time unit, and you 

should see the difference in the Current Location Panel. 

  

Select a Timeline Segment You can select a timeline segment on any data type on the 

Timeline Palette: 

 

1. On the Timeline Palette, click to set an anchor point. 

2. Drag your mouse over a data type (i.e., Audio, Video, 

Application Data, Text, Slide, Web Page, or Attendee), 

or on the timeline itself. 

3. Release your mouse. 

4. The selected segment is then highlighted by a red line at 

the bottom of the data type or the timeline. 

 

 Once a timeline segment is selected, its start time and end 

time are shown at the Segment Panel. 

 

Specify a Range You can specify the range of timeline to be displayed in the 

Timeline Palette, by doing either of the following: 

  

� On the toolbar, select View > Range. On the Specify a 

Range Palette, edit the Start time and/or End time and 

click OK. 

� Right-click a selected timeline segment and select 

Range. On the Specify a Range Palette, edit the Start 

time and/or End time and click OK. 

 

Once a Range is specified, Timeline Palette shows only the 

recorded data in the specified range. 

 

You can click Reset button on the Specify a Range Palette 

to get back to the full-range Timeline Palette of a JNR file. 

 

Auto Arrange Palettes On the toolbar, select View > Auto Arrange Palettes to get 

back to the default Jeditor workspace layout. 
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Language Support language selection
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Preview a JNR File 
 

 To preview a JNR file with Jeditor, just right-click the .jnr 

file and select Jeditor to open the JNR file.  

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 You can also launch Jeditor from the Start menu:  

 

1. On the Start menu, choose Programs > HomeMeeting 

> Jeditor > Jeditor. 

2. Click File > Open and browse to the location of the .jnr 

file. 

3. Click the JNR filename, and then click Open. 

 

Viewing Text Chat If necessary, you can drag out the Text Chat Palette from 

the Jeditor Workspace and look up all the text chat inputs 

by attendees. To put the Text Chat Palette back to the 

Jeditor Workspace, just double-click on its header or drag 

it back to the workspace. 
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You can also select a timeline segment on the Text bar, and 

the Information Palette will display the text chat inputs 

within that specific segment. 

 

On the Text Chat Palette, right-click a text chat and select 

Cut to cut it—or Restore to undo the cut. You can select 

Copy Time and paste (CTRL-V) the exact time to other 

Time field. 

 

Viewing Web Page You can look up a list of joint browsing URLs from the 

URL Palette or, as described in the previous paragraph, you 

can select a timeline segment on the Web Page bar and the 

Information Palette will display the URLs within that 

specific segment. Then, on the Information Palette you can 

click a URL to browse the corresponding website 

automatically. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

On the URL Palette, right-click a URL and select Set to 

Blank Page to blank the URL. You can select Copy Time 

and paste (CTRL-V) the exact time to other Time field. 

 

On the URL Palette, Right-click a “blank page” and select 

Restore URL to undo the action. 
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Viewing Slide You can look up a list of uploaded slides from the Slide 

Palette or you can select a range along the Slide bar to 

show slide viewing activities on the Information Palette 

during that selected timeline segment. Note that, along the 

Slide bar, green line indicates slide uploading, while blue 

line indicates slide viewing by all attendees. 

 

 You can double-click a slide name on the Information 

Palette to bring up the Slide Preview window. On the Slide 

Preview window, you can click File > Save As… to save 

the slide. On the other hand, you can right-click a slide 

name on the Slide Palette and select Display to view the 

slide or select Save As… to save the slide to your PC. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

On the Slide Palette, right-click a slide (or file), select 

Change Name to bring up Change Slide Name window, and 

type the new slide name in the New Name filed and click 

OK. 
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You must use the same file type, e.g., jpg, or end with 

blank page for a blank-page slide, when renaming a slide. 

You can select Copy Time and paste (CTRL-V) the exact 

time to other Time field, or select Set Bookmark to insert a 

cue point—please refer to Section “Finalize a JNR File”. 

 

Jeditor Permit Please note that you need to obtain Jeditor Permit from a 

Jeditor-Enable HomeMeeting server to edit a JNR file. 

Please refer to Jeditor Installation Guide for more details. 

 

Support G.726.11 In addition to our proprietary audio code, Jeditor 1.8.0 not 

only supports public audio code such as G.711, G.726, and 

iLBC, but also G.726.11 of higher sampling rate used by 

the feature of Start Recording. 
 

Application Data Application Data represents data flows from Desktop 

Sharing and Remote Control. In this version, Jeditor shows 

the starting points of Desktop Sharing and Remote Control, 

a click at the starting point bring up the details in the 

Information Palette. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Search Support text search in Text Chat, Slide, URL, Bookmark, 

and Attendee Palette. 
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My Picture Using JoinNet 4.5.0, or higher version, a user can pre-select 

an image as My Picture showing to other users during an 

online meeting or a recording playback, without using a PC 

camera. Jeditor 1.6.0 supports My Picture editing through 

the Attendee Palette. 

 

Add My Picture If an attendee did not use My Picture during a JoinNet 

recorded meeting or presentation, you can add a My Picture 

to that user: 

 

1. Right-click the user name in the Attendee Palette. 

Select Add My Picture. 

2. At the Open window, browse and select an image and 

click Open. Please note that the image’s aspect ratio 

should be a width-to-height ratio of 1.22 and a file size 

of less than 1GB, or preferably less than 100KB. 

 

Please note that, even My Picture is added to a JNR file, if 

the original video data is still available, or undeleted, 

JoinNet will display video instead of My Picture.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Edit My Picture You can modify, delete, restore, or show a user’s My 

Picture. 
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Default Video (Revision) During a JNR playback, JoinNet main video window 

displays the video stream from the first questioner when 

there are multiple video streams during a given timeline 

segment. Or it will show the only available video stream 

that it received. With the help of setting Default Video, a 

user can select which video stream, or My Picture image, to 

be displayed on the main video window. 

  

You can reset the default video on the Attendee Palette as 

follows: 

 

1. Right-click an attendee and select Add New Default 

Video Indicator to bring up Default Video Indicator. 

 

 

 

 

 

 

 

 

 

2. Specify the Time that you want the attendee’s video (or 

My Picture) to be displayed on the main video window.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note that, under the Eligible time range, show the start 

and end time of the attendee, and the beginning times of 

his/her My Picture and video as well. The time 

specified must be subjected to these eligible times. 

 

3. Click OK to add the specified default video (or My 

Picture) to the Default Video Palette. 
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Default video setting saved. 

Default video setting unsaved. 

Default video setting removed (unsaved). 

 

User Index denotes the order of attendee joining an online 

meeting. For example, “0” denotes a web office owner, “1” 

the first visitor, “2” the second visitor, and so on.  

 

You can also set default video during Play Audio & 

Video—click Default Video button to bring up the Default 

Video Indicator window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Please note that, when you cut all data or video within a 

time range from a JNR file, the default video setting within 

that specific time range will be removed as well. 
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Play Audio/Video (Revision) You can play back a specific timeline segment of audio and 

video from a JNR file that you have selected. 

 

1. Select a timeline segment on the Audio or Video bar. 

2. Right click the segment and select Play Audio & Video 

to bring up the Select a User window. 

3. If there is multiple audio/video streams in the Select a 

User window, select a user name and click OK to start 

playback. You can pause and resume audio/video 

playback, or move the marker to any playback location 

on the selected segment. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Some of you might have noticed the new functions on the 

Play Audio & Video window, that is, Fine Tune Cut 

Range and Play Cut Audio (or Video). This is the major 

revision of Jeditor 1.9.0.  See Cut via Audio/Video. 



HomeMeeting Document: JoinNet Editor (Jeditor) User Guide   15 

Cut a JNR File 
 

You can use Jeditor to cut recorded data in a JNR file, 

including audio, video, text chat, and application data such 

as shared desktop and remote control. However, you cannot 

use Jeditor to cut slide and attendee nor can you cut a joint 

browsing URL—but you can replace a URL with a blank 

web page. 

Please note that you need to obtain Jeditor Permit from a 

Jeditor-Enable HomeMeeting server to cut a JNR file. 

Please refer to Jeditor Installation Guide for more details. 

 

 It is very easy to cut a text chat on the Text Chat Palette. 

 

Cut Text Chat On the Text Chat Palette: 

 

1. Select the text chat to be cut. 

2. Right-click and select Cut. You can also select Restore 

to undo the cutting. 

 

Define a Cut Block To cut audio, video, and application data, you need to 

define a cut block and select which data type to be cut. 

 

1. Select a timeline segment on the Timeline Palette. 

2. Right-click the segment and select Cut Selected Block 

to bring up the Cut Block window. 

3. Edit the Start time and/or the End time, and select a 

data type—All, Audio, Video, Text Chat, and 

Application Data—from the drop-down list.  

4. Click OK on the Cut Block window. 

 

Once a cut block is defined, it will be listed in the CutBlock 

Palette. You can right-click a cut block on the palette and 

select Restore Cut Block to undo the cut or select Modify 

to edit the cut block on the Cut Block window. 

 

Individual A/V Cut Instead of cutting all video and/or audio specified by a cut 

block, you can cut an attendee’s audio or video as follows: 

 

1. Select a timeline segment on the Audio or Video bar. 

2. Right-click the segment and select Play Audio & Video 

to bring up the Select a User window. 

3. If there is multiple audio/video streams in the Select a 

User window, select the user name whose audio or 

video you want to cut, and click OK to start playback. 
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4. Select Cut to bring up the Cut Block window. 

5. Edit the Start time and/or the End time, and select a 

data type from the drop-down list about the user’s video 

or audio 

6. Select OK on the Cut Block window. 

 

Again, this cut block will be listed in the CutBlock Palette. 

You can right-click the cut block on the palette and select 

Restore Cut Block to undo the cut or select Modify to edit 

the cut block on the Cut Block window. 

 

 

Cut via Audio/Video Jeditor 1.9.0 provides an easy way to define a cut range 

during audio/video playback.  

 

1. Check the Start Time and click Pause to set the start 

cutting point. 

2. Resume playback. Check the End Time and click Pause 

to set the end cutting point. 

3. Resume playback of the segment of your interest and 

uncheck both Play Cut Audio and Play Cut Video to 

confirm your cut range. 

4. Click Cut and select the media type from the pull-down 

list on the Cut Block window. Click OK to set cut 

block. 
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Save Your Cut    You can save a JNR recording file that you have cut. If you 

 have previously saved an edited JNR file, you can save a 

copy of the recording to another file. 

 

To save an edited JNR file: 

 

1. On the toolbar, click File and select Save (or Save As). 

2. Choose a location at which to save the JNR file. 

3. Type a name for the file in the File Name field. 

4. Click Open/Save. 
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Finalize a JNR File 
 

Adding a Bookmark You can add bookmarks to a JNR recording file, so that 

JoinNet viewers can quickly navigate to the cue point 

defined by a bookmark during a JNR file playback. There 

are a couple of ways that you can add bookmarks to a JNR 

file: 

 

On the Slide Palette: 

 

1. Right-click a slide name on the Slide Palette. 

2. Select Set Bookmark to bring up the Bookmark 

Information window. 

3. Type the title of the bookmark in the Description field. 

4. Click OK. 

 

 

 

On the Bookmark Palette: 

 

1. Right-click on the Bookmark Palette. 

2. Select Add New Bookmark to bring up the Bookmark 

Information window. 

3. Type the cue time for the bookmark in the Time field 

and the title in the Description field. 

4. Click OK. 

 

 

Find a cue time for bookmark could become easier if you 

select Copy Time at certain action on the other palettes and 

paste it onto the Bookmark Information window. For 

example, a bookmark could be at a point where text chat 

was typed, a URL browsed, a default video to be displayed, 

and the like. 

 

 

Please note that, when you cut all data within a time range 

from a JNR file, the bookmark within that specific time 

range will be removed as well. 

 

Bookmark cue point setting saved. 

 

Bookmark cue point setting unsaved. 

 

Bookmark cue point setting removed (unsaved). 
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Here is a snapshot of a JoinNet playback with bookmark: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Set JNR Password On the toolbar, click File > Properties and bring up JNR 

properties. Under the Summary tab, you can set a password 

for the JNR and you can rename a JNR title—these two 

features are also provided by the JoinNet Messenger if the 

corresponding HomeMeeting server supports this feature. 

 

 

Lock a JNR File Under the Summary tab, you can lock a JNR file by 

selecting the checkbox “Lock JNR”. Once a JNR file is 

locked, no one can edit the file anymore, including all the 

fields under the Summary tab.  

 

 Information under MCU Information tab and Editor tab 

cannot be edited.  

 

MCU Information, for example, IP address and license 

number, was written by the MCU server from which a JNR 

file was created. 

 

Editor information is written by the Jeditor, based on the 

Jeditor Permit received from a HomeMeeting Server that 

has subscribed Jeditor feature. 

 


