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LIMITATION THE IMPLIED WARRANTIES OF MERCHANTABILITY, 
NONINFRINGEMENT AND FITNESS FOR A PARTICULAR PURPOSE, WITH 
RESPECT TO THE SAME. HOMEMEETING INC. SHALL NOT BE RESPONSIBLE 
FOR ANY DAMAGES, INCLUDING WITHOUT LIMITATION, DIRECT, 
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THE USE OF, OR OTHERWISE RELATED TO, THIS INFORMATION OR ANY 
OTHER DOCUMENTATION. NOTWITHSTANDING ANYTHING TO THE 
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TERMS AND CONDITIONS OF THE APPLICABLE LICENSE AGREEMENT 
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What’s New in JoinNet 5.1.1 
 
Echo Cancellation JoinNet 5.1.1 allows user to enable acoustic echo cancellation to 

avoid loopback from the audio output such as external speakers, if 
the user’s sound card supports such a feature. Simply go to 
Settings, then Advanced Options, and under the Audio tag one can 
check and turn on this feature. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
File Download JoinNet 5.1.1 will display a file icon on the Whiteboard when a 

user browses an uploaded file. Click on the file icon and select 
where the file will be downloaded and saved. 
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Overview 
 
 
JoinNet is the multimedia communication client software developed by HomeMeeting. 
And it is free. Generally speaking, functionality of JoinNet can only be activated when it 
establishes connection to a HomeMeeting’s meeting server, namely the MCU server.  
 
Once JoinNet connects to a MCU server, you can start online collaboration with other 
participants using audio, video, and text chat. Participants can also share and discuss 
slides, figures, documents, website, desktop, and even control other attendee’s PC or 
laptop remotely. Here is a snapshot of JoinNet user interface: 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
A MCU server supports multiple JoinNet connections in a meeting.  During an online 
meeting, JoinNet users are characterized into four roles, briefly described here. 
 

�  Coordinator. Coordinator (or meeting room Owner) can schedule an online 
meeting and invite meeting participants in advance, or he can launch an instant 
meeting and allow visitors to enter his on-going meeting room. The Coordinator 
moderates a JoinNet meeting by exercising control over a Token, which grants 
certain privileges to a Token Holder—that will be mentioned later. There is only 
one Coordinator in a meeting room and only the Coordinator can retrieve the 
Token from a Token Holder. 

Meeting Room 

Control Panel 

Interactive Board: White Board/Joint Web Browsing/ 
Shared Desktop/Remote Control 

Text Chat 
Window 

Video Windows 
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�  Token Holder. A Token Holder is the participant who holds the Token. Whoever 
gets the Token becomes the Chairman of an online meeting: when he talks 
everyone hears him; whoever wants to talk must get permission from him; 
whenever group consensus is needed he initiates a just-in-time voting. Whoever 
gets the Token becomes the Presenter in the online meeting room: he can print 
and present slides, upload files, annotate on slides, and share whatever application 
currently running on his PC or laptop to all other participants. A Token Holder 
can allow other participants to speak at the same time while he is talking. In short, 
a Token Holder is in charge of a meeting until the Coordinator retrieves the 
Token from him, or until he passes the Token to another participant. In the 
beginning of an online meeting, the Coordinator holds the Token. 

 
�  Questioner. Every meeting participant can ask question and prepare to talk, but it 

is the Token Holder who grants the permission to talk. Upon receiving the 
permission, a participant changes his role from an audience to become a 
Questioner—all participants hear his audio, and he can also upload 
files/slides/image/text to the White Board as the Token Holder does. 

 
�  Audiences. The rest of the participants can see and hear the Token Holder and 

Questioners, as well as their joint annotation/commenting on any uploaded slide. 
All participants can use public or private text chat to communicate among 
themselves. 

 
The Token Holder can moderate a JoinNet meeting through the Control Panel of JoinNet, 
such as allow question, end question, pass the Token, disconnect a participant from the 
meeting, conduct a just-in-time voting, and upload poll results to the White Board of 
JoinNet. There are many privileges for the Token Holder that will be mentioned in the 
later parts of this technical guide. Through the Control Panel, participants can identify 
who is in the meeting, who is the Token Holder and who are the Questioners. 
 
This user guide contains the basics for starting and moderating a JoinNet meeting, that 
includes 
 

�  A list of the system and software requirements 
 

�  General JoinNet features 
 

�  Advanced JoinNet features 
 

�  Technical troubleshooting 
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Minimum Hardware and Software Requirements 
 
 
Running JoinNet is computational intensive for a PC or laptop, especially for the Token 
Holder and Questioners who send out their video and audio at the same time they receive 
audio and video from others. These computational tasks include video capture and 
encoding, audio capture and encoding, data encryption and decryption, video decoding 
and rendering, and audio decoding and rendering, etc. The system requirements for using 
JoinNet are given here. 
 
General Requirements for Using JoinNet: 
 

�  Processor: Pentium III 333 MHz or higher, 600 MHz minimum CPU is strongly 
recommended for desktop sharing 

�  Operating Systems: Windows 98 SE and Windows ME (for JoinNet version 4.5.0 
and earlier), Windows 2000 Professional, Windows 2000 Server, Windows XP, 
Windows 2003, and Windows Mobile 

�  RAM: 64 MB or higher, 256 MB are recommended for desktop sharing 
�  Browser: Microsoft Internet Explorer 4.0 or higher, and Mozilla Firefox. 
�  256-color display adapter at least 800x600 resolution, but 16 bit-color at 

1024x768 resolution or higher are recommended 
�  Sound Card: You must have a full-duplex sound card to transmit and receive 

audio. Echo cancellation function is only available for compliant sound cards 
running on Window XP/2003 platforms. 

�  Microphone and Speaker: Use a headset that incorporates a microphone and 
headphone(s) or a speakerphone that includes “Echo Cancellation” technology is 
recommended. A headset that contains a boom microphone performs is the best. If 
a desktop microphone is used, a unidirectional dynamic microphone with batteries 
is preferred. If you do not use a microphone that includes a headset, other 
participants in the meeting will experience echo and feedback problems. 

�  Video Camera: No special software or hardware is required to receive video, but 
USB PC camera is strongly recommended. 

  
Download and Install JoinNet 
 
Before you attend a meeting or test your audio and video for the first time, you need to 
install JoinNet. JoinNet is a proprietary client software developed by HomeMeeting and 
it can be download at the website http://www.homemeeting.com/ where a technical paper 
called JoinNet Installation Guide is available for the step-by-step installation and audio 
setup. Please follow JoinNet Installation Guide to install JoinNet properly and to test and 
configure your audio and video settings. At the end, if you experience difficulty in 
connecting to a MCU server, you can refer to the troubleshooting section of this technical 
guide to find a possible solution to that problem. 
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Audio & Video 
 
 
Knowing when to talk Every meeting participant must get permission from the 

Token Holder before he can talk, unless the Token Holder 
should enable Auto Allow Question. One should always 
check the status of the following buttons in the Meeting 
Room window before start talking.  

  
 Audio is disabled. If you want to talk, click on this button 

and wait for permission from the Token Holder. 
 
 Audio is enabled—if you want to end talking, click on this 

button to stop sending out your audio.  
 
 When this button lights up, you can talk to all attendees. 

You should notice a microphone volume indicator 
appeared under the main video window. You can now 
interact with the Token Holder at the Interactive Board. 
You can click on this button to mute your microphone. 

 
 Microphone is muted—click on this button to un-mute your 

microphone. If you use external speakers and audiences 
hear echo from the Token Holder, you better mute your 
microphone to stop audio looping. 

 
Managing videos Video consumes a lot of bandwidth and it may affect the 

audio quality! But video does provide a good experience 
for an online meeting. Be sure to manage your video view 
wisely to maintain a good audio quality during an online 
meeting. 

 
 You are sending out your video—click on this button to 

stop sending out video. 
 
 You have stopped sending out video—click on this button 

to start video sending. 
 
 You are receiving videos from all people who are talking—

click on this button to stop receiving all video.  
 
 You have stopped receiving video(s) from all people who 

are talking. For users with poor Internet connection stop-
receiving video can greatly reduce their bandwidth 
consumption, and thus improve audio quality. 
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Take a picture Using a PC camera you can capture a just-in-time picture 

and upload the captured image to JoinNet’s White Board to 
be viewed by all meeting participants.  

 
 Click on this button to start PC cam image capturing. The 

Ready to Capture dialog box appears. Click OK button to 
capture the live video image from the main video window. 

 
Finally type in the filename, or use the default filename, 
and then click Upload button to send the image to the 
White Board—or click Cancel to stop taking picture.  

  
 
   

 
 
 

Recording in progress The entire JoinNet meeting is recorded for future playback, 
which includes audio, video, text chat, and all the user 
activities at the Control Panel and the Interactive Board. 
Only the Coordinator can stop recording audio and video. 

 
 Recording in progress! If you are the Coordinator or Owner 

of an online meeting, you can click on this button to stop 
recording audio and video, but the Coordinator cannot 
stop the recording of other data communications, which 
include the activities from the Control Panel, the Interactive 
Board and the Text Chat window. 

 
 Audio-and-video recording is stopped. Click on the button 

to resume audio/video recording, if you are the Coordinator 
or Owner of an online meeting room. 

 
 
Switch video views You can select video view at the main video window—

simply right-click on the main video window and a name 
list dialogue box appears, showing all available video 
views from attendees currently talking. In the list, select the 
attendee’s video you want to see. If the person you select 
does not have PC cam or he has stopped sending video, you 
will see a big smiling face. 

 
 Of course, you can also select Self View or Full Screen 

display. By one click at the full-screen display, you can end 
the full-screen. 
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Permission to talk This button is only for the Token Holder—it is shown at 

the same place as the button of “audio-is-enable” for other 
participants. When this button flashing, people are waiting 
to be allowed (to talk) by the Token Holder. In fact, 
entertaining questioning is better handled by using the 
Control Panel. See detailed instruction in Control Panel 
section. 

 
 
Multiple Videos Though you can switch videos between the Token Holder 

and other Questioners at the main video window, but 
nevertheless it still displays one video at a time. To view 
multiple videos at the same time, you can select multiple 
video viewers from the Video Window—a container of 
simultaneous video windows for those who are currently 
talking. You can also drag out any of the video window 
from the container and resize it. 

 
 
 
Auto Request Video When using previous version of JoinNet, you need to 

manually select participant’s video in the Video Windows, 
one by one, to display his/her video. The original purpose 
of this “inconvenience” is to reduce bandwidth 
consumption and computational loading at the 
HomeMeeting MCU server. 

 
 Now for customers who need no worry about the 

bandwidth resource and hardware capacity, JoinNet 4.5.0 
allows individual user to activate Auto Request Video 
setting within the JoinNet configuration file, joinnet.ini. 
Here is how one does it: 

 
1. Go to ~\HomeMeeting\JoinNet folder. Open the 

JoinNet configuration file, joinnet.ini (a text file). 
2. Set AutoRequestVideo=1 
3. Save and exit joinnet.ini. 

 
 
My Picture Find yourself an image that you like and show it to other 

participants as “My Picture”, during an online meeting or 
publishing a recording file, without using any PC camera. 
A perfect aspect ratio of your image is width-to-height 1.22 
with its file size less than 1GB, preferably less than 100 
KB.  
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Here is how it works: 
 
1. Go to ~\HomeMeeting\JoinNet folder and launch 

MyPicture. 
2. Browse the image file of your choice as My Picture. 

Click OK. 
3. Disconnect your PC camera or set the value of Detect 

Camera to zero in the JoinNet configuration file, 
joinnet.ini.  

 
 
 
Start Recording In addition to our proprietary audio code, JoinNet 5.0.0, 

and higher versions, not only supports public audio code 
for online meeting, including G.711, G.726 and iLBC, but 
also G.726 with higher sampling rate for online recording 
of better audio quality—and higher bandwidth consumption 
of about 43 Kbps. 

 
 A web office owner can use Start Recording to produce a 

no-data-loss, better-audio-quality recording file. All the 
data will be queued locally and then send to MCU using 
TCP. When a user launches Start Recording, his/her online 
status becomes Appear Offline to avoid any disturbing 
visiting request that could interrupt the ongoing recording 
session. When the user finishes recording by exiting 
JoinNet, his/her online status will be resumed to the 
previous one. 
 
Note: This feature is available only for MCU server with 
Enable Playback Connection. 

 
Changing Audio Device JoinNet users can now change their audio device in real 

time when running JoinNet: 
 

1.  Select Advanced Options under Settings; 

2.  Uncheck “Use default recording device” (or “Use 
default playback device”) and select new audio device 
from the pull-down list, if there is any other audio 
device available. 

 
This feature is typically useful for those users who have 
more than one audio device installed in their PC and are not 
sure which device they are using when running JoinNet—
especially when experiencing audio loop-back caused by 
the audio device come with a web cam. 
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Enlarge Video JoinNet 5.1.0 allows Token Holder to enlarge the size of 
his/her video synchronically to all viewers. 
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Interactive Board—White Board 
 
Can I draw? If you can talk, you can draw. Both the Token Holder and 

Questioner(s) can use the drawing tools to annotate on the 
slide at the White Board, currently selected by the Token 
Holder. 

 
 
 Click to show pointer or click-and-drag to frame. 
 
 Click-and-drag to draw—and release the mouse to print 

whatever you draw onto the White Board. 
 
 Click-and-drag to select a block for text typing—and click 

outside the block to print whatever you type onto the White 
Board. 

 
 Click-and-drag to draw a line—and release the mouse to 

print the line you draw onto the White Board. 
 
 Click-and-drag to draw a rectangular—and release the 

mouse to print the rectangular you draw onto the White 
Board. 

 
 Click-and-drag to draw an ellipse—and release the mouse 

to print the ellipse you draw onto the White Board. 
 
 Click-and-click to select the pinnacles of a polygon—and 

double-click at the end to close the polygon and print it 
onto the White Board. 

 
 Click-and-drag to draw color mark—and release the mouse 

to print the color marker you draw onto the White Board. 
 
 Click-and-drag to select an object at the White Board—

after that, you can click, drag, and move the selected object. 
 
 Click-and-drag to specify an area and then, inside that area, 

right-click to Paste an image, or a text block. But before 
doing this, you need to copy an image, or a text block, to 
the clipboard. Note: if you fail to paste a copied image or 
text block from Word or PowerPoint, you should try to 
paste it to Notepad (or Paint) first and then copy-and-paste 
it from Notepad (or Paint) to the White Board. 

 
 Click-and-drag to erase any mark, or image. 

Pointer 

Free Hand 

Text Mark 

Line 

Rectangular 

Ellipse 

Polygon 

Marker 

Select 

Paste 

Eraser 
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How to add slides? Both the Token Holder and Questioner(s) can upload 
slides. But only the Token Holder can decide which slide to 
be displayed at the White Board for all participants, namely 
group viewing. Everyone can flip slides locally at his PC or 
laptop, namely individual viewing. Every participant can 
download and save slides (or files) to his PC or laptop, but 
as Token Holder switching slide, this individual download 
could be interrupted. JoinNet offers many ways to add 
slides onto the White Board. Here are some examples. 

 
 
JoinNet Printer (no icon) Token Holder and Questioners can print slides of any 

printable format onto the White Board using the JoinNet 
Printer that is installed to your PC together with JoinNet—
and becomes the default printer when JoinNet is running.  

 
First you open a printable file, e.g., Microsoft Word or 
PowerPoint file, and then select Print  command—the same 
way you print the file to a printer—to print the file onto the 
White Board. And each page becomes a slide of image. 
 
Be sure that JoinNet Printer is selected if you want to print 
file onto the White Board—and make sure that “Print to 
file” is uncheck. 
 
JoinNet will then prompt to print the file to the JoinNet 
White Board with a pop-up dialogue showing the first page 
of the print image. 
 
Finally, click on Upload button to upload the slide(s) to the 
White Board. 
 
 

Window Capture Open an application with special printing process such as 
AutoCAD (or web browser), or application without Print 
command such as Real Player or Media Player. Then adjust 
the window size of that application to the size of your 
preference and capture the application to the White Board.  

 
 Click the Slide/File      icon and select Window Capture to 

bring up Capture dialogue box, showing a list of all 
applications currently running on your computer. In the list, 
select the application you want to capture to the White 
Board. Click OK to upload the window capture of that 
application to the White Board. 
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Add Slide This is good for uploading an image with filename 
extension such as BMP, GIF, JPG, or plain text file such as 
TXT. 

 
 Click the      icon and select Add Slide and the Add Slide 

dialogue box shall appear. Click Browse button to select 
the image or plain text file, and then click OK button to 
print it to the White Board. 

  
 
Print Screen (no icon) Use the standard Print-Screen (Fn-Prnt Scrn) to capture the 

desktop and then paste (CTRL-V) the image to the White 
Board as a new slide. 

 
 
Drag-and-Drop (no icon) Use the standard drag-and-drop to get graphic files (JPEG, 

GIF, BMP) and plain text files (TXT) to the White Board 
as new slides. You can also use standard copy-and-paste to 
add images to the White Board as new slides. 

 
 
Add Blank Page  This is for adding a new blank page to the White Board. 
 
 Click the      icon and select Add Blank Page and the Add 

blank Page dialogue box shall appear—the check box of 
Add Blank Page should be selected. Click OK to add a 
blank page to the White Board. 

 
 
Add File  Click the      icon and select Add File. You can upload a file 

to be shared with other participants. Please note that there 
is no image display, a blank page, on the White Board 
when an uploaded file is selected.  

 
 
Delete (Save) Slide/File Click the      icon and select Delete Slide/File, or select 

Save Slide/File. 
 
 
 
How to view slides? Once there are slides uploaded by the Token Holder and 

Questioner(s), anyone can view slides independently and 
locally (individual viewing) or the Token Holder can bring 
everyone to the same slide at the same time (group 
viewing). 
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Next Slide Click the Next icon to view the next slide—if there is any 
“next” slide, this icon will be activated. 

 
 
Previous Slide Click the Previous icon to view the previous slide—if there 

is any “previous” slide, this icon will be activated. 
 
 
Slide Browser  Click at the Slide Browser to view all uploaded slides 

and/or file(s)—and then select a slide to view. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 This icon denotes a slide has been viewed (i.e., downloaded 

to your PC.) 
 
 This icon denotes a slide has not yet been viewed. 
 
 This icon denotes a file has been downloaded to your PC. 
 
 This icon denotes a file has not yet been downloaded. 
 
                                          * This icon denotes the slide currently viewed by the Token 

Holder. This is the slide you can annotate. 
 
 This icon, appears at the right-hand side of the Slide 

Browser, tells that there are new slides been uploaded to 
the Slide Browser. 

 
 
Full Screen Click this icon to change to a full-screen White Board. 

Slide Browser 
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What to do with slide? If you are “talking”, you can use the drawing tools to mark 
on the slide that is currently viewed by the Token Holder. 

 
 
Active Slide                      * As shown previously, this is the slide currently viewed by 

the Token Holder and this is the slide you can mark on—if 
you are “talking”. 

 
 
Clear All  This icon is available for the Token Holder only. Token 

Holder can click this icon to remove all marks. 
 
 
Undo Last Mark  Click this icon to undo last mark made by you, if you can 

make a mark. 
 
 
Save Slide/File Click this icon and select Save Slide to save the slide (or 

file) that you’re viewing to your PC or laptop, for all users, 
whether you are individually viewing the slide or group 
viewing the slide with the Token Holder. Please note that, 
if the Token Holder changes to a different slide (or file) 
while you’re saving slide (or file) under individual viewing, 
the file saving process may be interrupted and terminated. 

 
 
Customize Toolbar JoinNet 4.5.0, and higher version, allows users to 

customize their toolbar of the Interactive Board. 
 

1. Select Menu icon>View>Customize ToolBar. 
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2. Select tool you want and Add it to the current toolbar 
buttons, or Remove it from the toolbar, vise versa.  

 
 
 
 
 
 
 
 
 
 
 
 

3. Select text options: Show text labels, Text labels on 
right, or No text label. 

4. Close Customize Toolbar. 
5. Repeat the same procedure for other Interactive Board 

components, including White Board, Joint Web 
Browser, Shared Desktop, and Remote Control. 

 
Enlarge Buttons JoinNet 5.1.0 allows users to enlarge the size of the color 

panel on the Whiteboard. 
 

1. Go to ~\HomeMeeting\JoinNet folder and open 
joinnet.ini . 

2. Set Button Size=Large. Save joinnet.ini . 
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Private Note JoinNet 5.1.0 allows all participants to copy slides from the 

Whiteboard to the Private Note, but only Questioner can 
upload annotated slides from their Private Note. 
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Interactive Board—Joint Web Browsing 
 
How does it work? When a Token Holder visits a web site with plain-text URL 

(e.g., Google), all meeting participants are brought to the 
same site – via Joint Web Browser, this URL is sent to all 
participants in the same meeting.  

 
Note that, if the hyperlink is not a plain URL, such as web 
pages required authentication, the web page may not 
appears at other participants’ browsers, even it shows up at 
the Token Holder’s browser. It is better to use Shared 
Desktop in such a case. 

 
Web Page Capture Click Menu      , select File>Web Page Capture to capture 

the section displayed within the Joint Web Browser and to 
paste it to the White Board. For Token Holder and 
Questioner(s) only. 

Print  Click Menu      , select File>Print to print the entire web 
page, or all the associated web pages (if you set the printer 
to do this), to the White Board. For Token Holder and 
Questioner(s) only. 

Allow Popup Click Menu>File>Allow Popup to activate web popup 
checking—Yes to allow popup or No to stop popup. 

Stop Browsing Click Menu>Go>Stop to stop browsing the current web 
page. 

 
Next Page Click Menu>Go>Forward to go to the next web page you 

have browsed. 
 
Previous Page Click Menu>Go>Back to go back to the previous web page 

you have browsed. 
 
Start Page Click Menu>Go>Start Page to go back to the first web 

page you have browsed. 
 
Font Size Click Menu>View>Fonts to select font size (largest, large, 

medium, small, smallest) for web browsing, if the web site 
supports different font size. 

 
Refresh Browsing Click Menu>View>Refresh to refresh the current web 

page. 
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Interactive Board—Shared Desktop 
 
How does it work? This is for Token Holder only. You can share any 

application on your computer with meeting participants, 
including your entire desktop. Participants can view your 
application or desktop and all the actions that you are 
taking in real time. 

 
 
 When switching to Shared Desktop for the first time, the 

Token Holder can either click OK to share his/her entire 
desktop to all other participants or he can click Cancel and 
then select an application to share from the list of Visible 
Window. The Visual Window lists all the applications 
currently running on the Token Holder’s PC, including his 
entire Desktop. In the list, select the application that you 
want to share. 

 
Share During desktop/application sharing, this icon should be 

“down”, which indicates data sending out from the Token 
Holder’s PC or laptop. And this icon is disabled for the rest 
of participants. The Token Holder can stop desktop sharing 
anytime when he clicks this icon to bring it “up”, or he can 
select another application and then click this icon to start a 
new desktop sharing. You better make sure that this icon is 
at its down status while you are sharing. 

 
 This icon-down status indicates that you are sending out 

your shared desktop/application. 
 
Colors The Token Holder can select different color setting while 

sending out shared desktop (or application). For better 
image quality, you should select higher color level—and 
hence higher bandwidth consumption. On the other hand, 
for faster motion display, you should select lower color 
level—and hence higher CPU and random memory 
consumption. Color levels supported by JoinNet are 24 and 
16 bits, 256 colors, 16 colors, 4 colors, and 2 colors. In 
most of the cases, 256-color setting is strongly 
recommended. 

 
Window Capture Click Menu>Actions>Window Capture to capture a 

window image. This is mostly used by Questioners, who 
are allowed to talk by the Token Holder. Click this icon to 
capture the Token Holder’s shared desktop (or application) 
and then print it to the White Board. 
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Full-Screen Display Token Holder can click this icon to start a synchronized 

full-screen desktop sharing. Click OK to run synchronized 
full-screen or pressing Alt+Enter to end the full-screen 
display. Other recipients can click on their screen to end 
full-screen display and click this icon again to resume full-
screen display. 

 
 Note that, if an animated full-screen PowerPoint 

presentation is desired, the Token Holder should share the 
entire desktop—instead of the window of PowerPoint, start 
a PowerPoint slide show, and then click the full-screen 
displays. 

 
 This icon-down status indicates that you are receiving 

shared desktop from the Token Holder. 
 
Auto Stop Sharing Click the menu icon, and, under Action, select Auto Stop. 

Once this is done, desktop/application sharing will be stop 
automatically when the Token Holder switches to another 
Interactive Board mode such as White Board.  

 
 However, when continuous sharing is desire, the Token 

Holder should un-select Auto Stop. But even with 
continuous sharing, as the Token Holder switches from 
Shared Desktop to a new Interactive Board such as White 
Board, all other participants switch to the new Interactive 
Board together with the Token Holder. But the Token 
Holder can ask other participants to switch back to Shared 
Desktop to view his/her shared desktop. 

 
Effects on Token Holder By default, when the desktop sharing is activated, the 

following two actions are also applied to the Token Holder. 
 

·  The Token Holder won’t be seeing his/her shared 
desktop. Since the Token Holder is already viewing 
his/her desktop or application, there is no need to 
transmit the view from the MCU back to the Token 
Holder. Furthermore, if the View function of the Token 
Holder is on, recursion of the shared application or 
desktop will occur. 

 
·  The Token Holder’s video will be stopped during 

shared desktop. The Token Holder’s video is stopped 
for a better bandwidth usage.  
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Interactive Board—Remote Control 
 
How does it work? Remote Control enables a joint operation between the 

Token Holder and Questioner(s). With Remote Control, the 
Token Holder can control, or assign another Questioner to 
control, desktop or applications shared by one of the 
Questioners. At the same time, the rest of the meeting 
participants can view the real-time joint operation between 
the Questioner and the Token Holder (or another 
Questioner). Here is how it works. 

 
Are you talking? (1) Token Holder should allow the participant to talk or the 

participant asks question and become a Questioner. 
 
 (2) Token Holder selects Remote Control tab from the 

Interactive Board. 
 
Who control whom? (3) At the window of Remote Control, the Token Holder 

selects the Questioner(s)—or himself—from the drop-down 
list and clicks Control  button. Controller controls whom to 
be controlled. 

 
 
 
 
 (4) The user, whose PC or laptop is to be controlled, should 

see a prompt of remote control and he should click OK to 
allow full desktop control or Cancel to go to the next step.  

 
 
Share  (5) If the user, whose PC or laptop is to be controlled by the 

Controller, should have selected Cancel to the full desktop 
control, he can then select an application currently running 
on his PC’s desktop listed by the Visible Window and to 
allow remote control by the Controller for that particular 
application only. 

 
 This icon-down status indicates that the Controller is 

requesting control to another PC or laptop. 
 
 Click Menu>Actions: if Display is checked, it indicates the 

Controller is controlling other user’s shared desktop (or 
application). 

 
 Click Menu>Actions: if Share is checked, it indicates that 

one is allowing the Controller to control his desktop. 
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Control Panel 
 
What it does? Control Panel shows user activities. For the Token Holder, 

it can also be used to control questioning flow, to give out 
token, to check individual slide-downloading progress, and 
to exercise just-in-time voting. From Control Panel, 
everyone in an online meeting can see the audio-video 
statuses of other participants. Whoever gets the token will 
be red-highlighted. 
 
 
 
To moderate an online meeting, the Token Holder clicks on 
the name of the participant and selects the corresponding 
actions to assign (or to allow) the participant to talk, to 
view his/her video, to end, or skip, his/her questioning or to 
end all questions (i.e., to stop all others’ talking), to pass 
out token, or even disconnect the participant out of an 
online meeting. Retrieve token is only available for the 
Coordinator (or meeting room Owner). 
 
 

User list Under this icon, participants’ names are listed according to 
their order of entering. Click this icon for user name 
sorting.  

 
Talk Status  Under this icon, Questioners, as well as the Questioner(s) 

to-be, are denoted by three statuses. Click this icon to sort 
out Question Askers. 
 
 You are allowed and ready to talk; 
 
 Other people are talking, with audio signal monitor 

 
 Waiting for talk permission (for Token Holder only) 
 

Video Device Under this icon, users’ video-device capabilities are listed. 
Click on this icon to sort out users’ video-device 
capabilities. 
 
 Video device enabled 
 
 Video device temporarily disabled 
 
 No video device was detected 
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Slide Download Under this icon shows the slide downloading progresses for 
all participants. Click this icon to sort out individual slide-
downloading progress—for Token Holder only. Before one 
continues talking on a new slide, he better makes sure that 
everyone has completed downloading the new slide. 

 
Poll and Vote Under this icon shows the polling choices from all 

participants. Click this icon to sort out the polling choices 
of 1, 2, 3, 4, and 5. Note that the Token Holder needs to 
wait at least 30 seconds to get the poll result, or to start a 
new voting. 

 
Here is how the Token Holder starts a just-in-time voting: 
 
(1) Click at Control Panel and select Poll 

 
(2) All participants will be prompted with a Poll Request 

dialogue box  
 

(3) Every participant has 30 seconds to make a poll out of a 
scale from 1 to 5 

 
(4) After 30 seconds, the Token Holder can view the poll 

statistics by selecting Poll Result, and/or upload the 
poll result to the White Board 
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Advanced Features 
 
JoinNet Menu There are four menus provided by JoinNet, i.e., File, Tools, 

Settings, and Help. You can find all the advanced features 
inside these menus. 

 
File Open, Quit Web office, Exit 
 
Tools Interactive Board, Control Panel, Playback 

Control Panel, Statistics, Video Window, SIP 
Phone, Snapshot w/ Color 

 
Settings Stop Video, Mute Microphone, Recording, 

Advance Options, Do not Disturb, Auto Allow 
Question, Auto Allow Visitor, Ring 

 
Help Contents, About JoinNet 
 
Some of the features within these menus have been 
introduced earlier and some can be intuitively understood. 
The rest of them (italicized) require further explanations:  

 
 
Quit or exit? Most users will exit JoinNet to terminate the program. But 

if you are the Coordinator, you have two choices: (1) Quit 
Web Office to keep the on-going meeting alive and leave 
the token to one of the participants remaining in the 
meeting—and come back later, or (2) Exit to end the 
meeting and disconnect all participants. 

 
Open a recording file Play a recording file that was downloaded to your PC. 

JoinNet recording file is saved with a filename extension 
“*.jnr”. And check Messages to display online messages. 

 
Check your bandwidth Select Statistics to display audio/video transmission-and-

receiving bandwidth. 
 

Bandwidth requirement indicates the total bandwidth set by 
the JoinNet. 
 
Video target rate indicates the available bandwidth 
allocated for video. Note that 
 
Audio target rate = (Bandwidth requirement)–(Video target rate) 
 
If audio jitter is high, you better Stop Video. 
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SIP phone call out Pop up SIP Phone call-out window—this feature will be 
enabled only when you connect to a special MCU server.  

 
There are two call-out options for Call: Call SIP phone or 
Call Telephone. When the P2P connection established 
between JoinNet and the other telephony device, the 
JoinNet user can decide whether or not to bring the 
telephony-device user to join the meeting and to audio-
conference with the Token Holder and other Questioners.   
 
Please consult your local HomeMeeting agent to take 
advantage of this special feature. 
 
 

Do not disturb! This is for the Coordinator only. After this feature is 
selected, forthcoming visiting requests will be denied 
automatically. 

 
Auto allow visitor!  This is for the Coordinator only. After this feature is 

selected, forthcoming visiting requests will be granted 
automatically. 
 

Auto allow question! This is for the Token Holder only. After this feature is 
selected, forthcoming talk requests will be granted 
automatically. Note that your system administrator set the 
maximum number of Questioners. Four (4) people talking 
at the same time is a common setting, namely one Token 
Holder and three Questioners. Once reaching this 
limitation, the Token Holder has to grant permission to talk 
manually—and keep the last Questioner floating. 

 
Ring! Ring! Ring!  This is for the Token Holder only. When there are people 

waiting your permission to talk, your PC rings! You can 
certainly uncheck this to turn off the ring. 

 
Advanced Options There are four advanced options here: Audio, Video 

Options, Network Settings, and Language Settings.  
 
 Video Options deals with camera settings, snapshot 

whiteness threshold, and, most importantly, the preference 
of your video to be viewed by others—Faster Video for 
higher frame rate and continuous motion, ideally for 
broadband Internet connection, and Better Quality for 
lower frame rate and better frame-by-frame image, ideally 
for narrowband Internet connection. 

 



HomeMeeting Document: JoinNet User’s Guide   25 

 Language Settings allows you to choose among different 
language provided by the JoinNet GUI, or to enable 
Unicode text input/output (UTF8) for multi-language 
display, and to translate received Chinese Characters 
between traditional Chinese and simplified Chinese. 
 
Audio Settings allows you to configure your audio device 
when you experiencing audio problem (to be covered in the 
next section for troubleshooting), to enable silent detection 
that stop sending background bits when speakers are silent, 
and to enable acoustic echo cancellation which is system-
dependent and hardware-dependent. Also, you can set the 
JoinNet’s audio buffering: increase audio buffering to 
improve audio quality when experiencing audio jitter.   

 
Networking Settings allows you to set the proxy server 
that handle your company’s Internet traffic, and to set the 
MCU relay server that reduce bandwidth consumption by 
consolidating your company’s JoinNet connections into a 
single connection when joining an online meeting at 
another MCU. In case that audio/video data is filtered by 
firewall—no audio and video, but text chat is OK—you can 
use TCP to solve the problem. If other people in the same 
meeting complaining your audio quality, you can reduce 
your up-stream bandwidth that slow down your video 
transmission to others. 
 

Bookmark Playback Double-click a bookmark to playback at the desired session 
of a JoinNet recording file (JNR file)—this feature is 
available only when a JNR was edited by HomeMeeting 
Jeditor software. 
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JoinNet Layout 
 
You can customize JoinNet layout according to your personal preference. First open the 
JoinNet configuration file, joinnet.ini for meeting and JnPlay.ini for playback, under the 
directory where you install JoinNet, typically it is under the directory 
~HomeMeeting/JoinNet: 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Size of Main Window You can define the size of the JoinNet main window by 

specifying its length and width in pixel—and using the 
value of –1 to use the default value of your screen settings. 
Here is an example size of JoinNet main window, using 
800x600 for a desktop screen size of 1024x768: 

 
 MainWindow=800,600 
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What is Splitter? JoinNet uses splitter to divide its layout. There are two 
splitters used by JoinNet: the Splitter0 and Splitter1. 
Splitter0, by default, contains Meeting Room, Control 
Panel, Text Chat Window, and Bookmark Window; 
Splitter1 contains Video Windows by default. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
   

“FullLength=0” means Splitter0 takes the full length; 
while, “FullLength=1” means Splitter1 takes the full 
length. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Dock the Splitters You can customize the JoinNet layout by docking the 

Splitters to where you want them to be. Here are two 
examples: 

 

Splitter0 

Size 
Splitter1 
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 [Splitter] 
Splitter0 Dock=Right 
Splitter0 Size=-1 
Splitter1 Dock=Bottom 
Splitter1 Size=-1 
FullLength=0 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

[Splitter] 
Splitter0 Dock=Top 
Splitter0 Size=-1 
Splitter1 Dock=Right 
Splitter1 Size=300  
FullLength=1 
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Moving the Windows Not only you can dock Splitters to right, left, top, or 

bottom, you can move windows between Splitters. Here is 
another example: 
 
[Splitter] 
Splitter0 Dock=Left 
Splitter0 Size=0 
Splitter1 Dock=Right 
Splitter Size=190 
 
[Splitter0] 
MainVideo=-1,-1 
 
[Splitter1] 
Multiple_Video=-1,340 
UserList=-1,100 
TextChat=-1,-1 
 
 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 

In this layout example, we hide Splitter0 by setting its size 
to zero, and we move two windows, User List and Text 
Chat, to Splitter1. 
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Troubleshooting 
 
Can’t hear you! Hear nothing? Does the other party get the permission to 

talk? You can verify this by checking his/her Talk Status at 
the Control Panel. If no audio signal showing at Control 
Panel, the other party must be experiencing network 
connection problem or audio settings problem. If the audio-
signal monitor showing green bars, you better check your 
audio settings. 

 
 
Check audio settings Before you start checking your audio settings, you should 

check the headset plug-ins, if you are using a headset—
don’t be surprised to find out that they are accidentally 
plugged into wrong jacks! 

 
 

Next, find the volume icon. The volume icon should be 
displayed alongside with the clock at the lower-right corner 
of your PC desktop. Just one click at it and you should be 
able to find out whether you have to uncheck Mute or you 
need to raise your audio volume. 
 
After all this, if you still can’t hear anything and Control 
Panel showing that you are receiving audio signals from the 
other party, you better restart your PC since it is possible 
that other programs are currently using the audio capture 
device or your PC or laptop is too busy. 
 
 

Can’t hear me? First make sure that you have the permission to talk (e.g., a 
microphone icon beside your name at Control Panel) and 
you see a volume indicator running (green, yellow, and red) 
just underneath the main video window. If not, and you are 
sure that you have allowed to talk by the Token Holder, 
then you need to configure your audio device. 

 
 First of all, under JoinNet’s Settings menu, select 

Advanced Options, select Audio, and then click 
Configure Audio Devices. 

 
 If you’re using Window XP, this will bring up Sound and 

Audio Device Properties. Select Audio tab: 
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 Click Volume to bring up Recording Control. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

If your audio settings are 
correct, and people still 
complaining about your 
audio, enable TCP at the 
Advanced Options. 
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If you’re using Win98, one click at Configure Audio 
Devices will bring up Multimedia Properties. Simply 
click the recording icon to bring up Recording Control. 
 
If there is more than one audio device on your computer—
some PC cam comes with audio device, you should select 
your default device for sound recording and make sure that 
Use only default devices—located at the bottom of Sound 
and Audio Device Properties—is checked. 

 
Even when you specify which audio device to use, some 
PC camera microphones must be disabled manually. To do 
so, go to Windows Device Manager, under Sound, video 
and game controllers double click the PC camera 
microphone device then select to disable the device. 
 

 
Echo! Echo! Echo! You need to find out the Questioner who is echoing back 

the audio from the Token Holder or other Questioner(s). 
This problem is exactly like the TV call-in program when 
the host asks call-in audiences to turn off their radios to 
avoid audio feedback. If this is the case, you should ask 
that person to turn off his external speakers or mute his 
microphone while you’re talking. 

 
 On the other hand, it may be caused by wrong audio 

settings of yours—you’re playing back your own 
microphone. Bring up Master Volume and make sure you 
mute your microphone. Microphone should be a recording 
device, not a playback device unless you want to talk (or 
sing) to yourself. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

(For Win 98) Click here 
to bring up Recording 
Controls 
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In some case, you need to disable Microphone Boost in 
Advanced control for Microphone to avoid echoing back 
other people’s audio. 
 

Can’t See Me? Are you a Questioner? Do you stop sending video? Does 
the other person select your video to view? Does he stop 
receiving video?  

 
Or does your PC cam work fine? To ensure that your video 
camera is working correctly, follow the procedures in your 
camera’s documentation. You probably won’t need to do 
anything to test and configure your video equipment. 
However, you should follow the instructions below for 
double-checking: 

 
·  Verify that your computer has USB support installed. 

To do so, open Settings, Control Panel, System, and 
under Device Manager you should see that you have 
the class Universal Serial Bus Controller for USB 
support.  

 
·  Install the correct driver for your PC camera. Follow 

the instructions on how to setup and install your PC 
camera provided by the camera manufacturer.   

 
·  Set the display adapter to 16bit colors for better 

performance. Note that the driver will not work 
properly with a setting of 256 colors. 
 

Note that, before starting JoinNet, make sure that you are 
not running any other videoconferencing software—any 
other software that records/streams/captures video through 
your PC camera, etc. 
 

Proxy? Firewall!  There is always dilemma between network security and 
ubiquitous communication. HomeMeeting realizes that in 
order to deploy communication services within cooperate 
data network the proxy/firewall issues must be resolved. 
The fact is: if you can do online transaction using HTTPS 
(or via port 443), you should be able to JoinNet other 
people in the world. In most of the cases, what you need is 
to use TCP for audio and video, and/or to equip JoinNet 
with proxy settings (refer to Network Settings under 
Advanced Options). 
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 Note: JoinNet supports Network Address Translators 
(NAT), which is handled automatically, and you do not 
need to set any parameters if you access Internet behind a 
NAT. 

 
If a proxy server is used, you need to add the proxy settings 
to JoinNet. These are the same settings as in your Microsoft 
Internet Explorer. To find out the required proxy settings of 
your network, if there is any: 
 
(1) Launch your web browser 
 
(2) Under Tools select Internet Options 

 
(3) Click Connections tab and choose LAN Settings 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

(4) If Proxy server is checked, copy its address and port 
number to JoinNet—under Settings menu, select 
Advanced Options, choose Networking Settings, and 
select Use a proxy server. 

 
Sometimes, the anti-virus program, or client-side firewall 
program, could stop JoinNet from connecting to MCU 
server, if you forget to configure your security software 
properly. 

 
 


